Forums

OverviewV-Play 2 Support (Qt 5) › QT 5.4

Tagged: 

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8570

    Nour

    Hi

    I just installed the latest version of QT and i cant deploy on android device

    i have this in compile output

     

    Application binary is not in output directory: /Users/mohammad/QT5/build-TrixQT5-Android_for_armeabi_GCC_4_8_Qt_5_4_0-Debug/android-build//libs/armeabi-v7a/libTrixQT5.so. Please run ‘make install INSTALL_ROOT=/Users/mohammad/QT5/build-TrixQT5-Android_for_armeabi_GCC_4_8_Qt_5_4_0-Debug/android-build/’ first.

    Generating Android Package

    Input file: /Users/mohammad/QT5/build-TrixQT5-Android_for_armeabi_GCC_4_8_Qt_5_4_0-Debug/android-libTrixQT5.so-deployment-settings.json

    Output directory: /Users/mohammad/QT5/build-TrixQT5-Android_for_armeabi_GCC_4_8_Qt_5_4_0-Debug/android-build/

    Application binary: /Users/mohammad/QT5/build-TrixQT5-Android_for_armeabi_GCC_4_8_Qt_5_4_0-Debug/libTrixQT5.so

    Android build platform: android-20

    Install to device: No

    15:04:24: The process “/Users/mohammad/Qt5.4.0/5.4/android_armv7/bin/androiddeployqt” exited with code 7.

    Error while building/deploying project TrixQT5 (kit: Android for armeabi-v7a (GCC 4.8, Qt 5.4.0))

    When executing step “Build Android APK”

    #8571

    Alex
    V-Play Team

    Hello,

    the log output unfortunately does not contain any useful hints regarding your issue,¬†does this also happen after an explicit “clean” & “qmake” from the build menu? Does this also happen for a “QtQuick Application” (from the project wizards)?

    Thanks,

    Alex

    #8666

    Nour

    Hi Alex

     

    I just fixed this problem by renaming the project,

     

    Thanks

    #8682

    Alex
    V-Play Team

    Thanks for letting me know, sounds like an issue with some old build artefacts.

    Best,

    Alex

    #9774

    Hung

    I have the same problem ,could you give me the right thing you did to solve it ,please !

    #9827

    Alex
    V-Play Team

    Hi,

    maysalward solved it by renaming the project. So the reason for this issue could have been e.g. some old references that didn’t get cleared, we couldn’t reproduce such an issue so we are also just guessing here.

    You could try creating a new project, then copy all your code and assets to the new project folder and run the new project instead. Maybe also just removing the shadow build folder and then run a “clean” command followed by a “qmake” command (rightclick on the project folder in Qt Creator to access those commands) could help.

    Regards,
    Alex

Viewing 6 posts - 1 through 6 (of 6 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support