Forums

OverviewV-Play 2 Support (Qt 5) › background music doesnt produce sounds

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #7589

    Vlad

    Hi

    weird situation. some time ago background music on my app just stopped to sound

    In the mean time it seems music itself is playing but no sound. All events like start playing, end playing works ok

    Looks like its muted but mute is set to false and volume is set to 1.0

    sound effects works ok

    what is may be a root cause of this?

     

    thanks

    #7603

    Christian
    V-Play Team

    Hi Vlad,

    can you please post sample code that shows this problem?

    Cheers, Chris

    #7604

    Vlad

    Sample code works just fine

    I think its project specific but cannot find what to reset

    #7613

    Vlad

    ok, found the root cause

    alsa/pulseaudio app settings was muted for specific pcm stream

    #7617

    Christian
    V-Play Team

    Hi Vlad,

    great you found it!

    Cheers, Chris

Viewing 5 posts - 1 through 5 (of 5 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support