Forums

OverviewV-Play Installation › V-play installation issue with Qt Android 5.7

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #13936

    V-Play User

    Hi

    I found issues with v-play installation in exiting Qt android, I just followed below step to update it(Qt Android 5.7 and Qt creator 4.0.2)

    • Select “Maintenance tool” than “Add or remove component” and clicked on “setting”
    • Select “Repository” and use this “https://sdk.v-play.net/2/windows” to update.
    • After this found below problem.
    1. Could not resolve dependency ‘Core(3.6.0)’
    2. Could not resolve dependency ‘ProjectExplorer(3.6.0)’
    3. Could not resolve dependency ‘Help(3.6.0)’

    Please do needful and revert ASAP….

    #13937

    Lorenz

    Hi,

    Unfortunately, we do not support Qt Creator 4.0 and Qt 5.7 yet.

    Support for both is on the roadmap for one of the next updates.

    In the meantime, please use V-Play with Qt 5.6 and QtCreator 3.6.1

    Note: If you set up the kits correctly, you should be able to use QtCreator 4.0 with V-Play, but offline documentation and our Qt Creator plugin will not work.

    All the best,

    Lorenz

    #13938

    V-Play User

    k

    Let me install Qt android 5.6, until could you provide a running Facebook login example on Android OS…

    #14177

    Alex
    V-Play Team

    Hi,

    Just wanted to let you know that V-Play supports Qt 5.7 and Qt Creator 4 since the update to version 2.9.0.

    Best,

    Alex from V-Play

    #14863

    Steve

    I just installed V-play using the exact method above on Windows and I get the same error on startup with the following differences using Qt Creator 4.1.0 with Qt 5.7:

    1. Could not resolve dependency ‘Core(4.0.3)’
    2. Could not resolve dependency ‘ProjectExplorer(4.0.3)’
    3. Could not resolve dependency ‘Help(4.0.3)’

    Is this an issue with V-ray support for Qt Ceator 4.1.x or is there another bug? Thanks

    #14867

    Günther
    V-Play Team

    Hi Steve!

    Yes, V-Play uses a custom Qt Creator Plugin, that is only compatible with the specific Qt Creator version we provide with our installers (Qt Creator 4.0.3 at the moment). You see these errors because the plugin does not work with Qt Creator 4.1.0.

    Best,
    Günther

    #14871

    Steve

    Thanks Günther,

    Eagerly waiting for the updated plugin.

    Thanks.

    Steve

    #15083

    Lucas

    hello regarding this issues I have 2 question… first one, the obvious and the bothering for you, is there any date of when the plugin is going to work with qt creator 4.1, and the second one, am I going to have any issue if I work with the versión 4.1???

    #15086

    Günther
    V-Play Team

    Hi Lucas!

    What I can say for sure is that the next V-Play update (probably next week) will still come with Qt Creator 4.0.3.
    When we will change to Qt Creator 4.1 for our plugin and installers is not fixed yet, but of course we will switch to the newer version some time in the future.

    The projects you are developing should also work normally with Qt Creator 4.1. The only issue when using Qt Creator 4.1 is that our plugin wont work and the annoying error message at startup concerning the plugin. Without the plugin, some features in Qt Creator are then not available or will be buggy, for example the V-Play update feature, where Qt Creator notifies you when a new V-Play update is available.

    Best,
    Günther

Viewing 9 posts - 1 through 9 (of 9 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support