Forums

OverviewV-Play 1 Support › PRV Issue "PVR: wglChoosePixelFormatARB"

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #5306

    Raimonds

    Hi,
    Is there any limitations to run project if i’m connected to pc with remote desktop connection?
    I got strange issue when i was logged in through rdc yesterday. Today in real pc no errors.

    —————————
    PVR Message
    —————————
    PVR: VFrame attempted to use one of these functions:
    PVR:     wglChoosePixelFormatARB
    PVR: but they are not present on your machine.
    Ignore?
    —————————
    Yes   No
    —————————

    Does not matter or click yes or no – project stops.
    Maybe someone else had this issue? Waiting for solution how to fix this, because almost half of work i do through remote desktop connection….

    Best regards,
    Raimonds

    #5307

    Alex
    V-Play Team

    Hi Raimonds,

    what desktop platform are you developing on? Are you using PVR images in your project? Does this also happen when you are running a normal Qt-Quick application remote?

    Cheers,
    Alex

    #5308

    Raimonds

    Hi Alex,

    Issue is repeated today. I’m connecting from my Windows7 environment to my other PC (Windows8) with remote desktop connection.

    If i run project from my Windows8 environment – everything is working well

    If i connect with rdc, then i have this error on all projects – even empty vplay qt project is not working

     

    Full error output

    Starting C:\Projects\_VPlay\untitledTest2-build-desktop-Qt_4_8_1_for_Desktop_-_MSVC2010__Qt_SDK__Debug\debug\untitledTest2.exe…
    Qt: Untested Windows version 6.2 detected!
    Qml debugging is enabled. Only use this in a safe environment!
    m_platform in System set to: 4 , m_isDesktopPlatform: true
    m_isDebugBuild in System set to: true
    Load config file from “C:/Projects/_VPlay/untitledTest2-build-desktop-Qt_4_8_1_for_Desktop_-_MSVC2010__Qt_SDK__Debug/qml/config.json” , adjustedFileName: “qml/config.json”
    Setting default orientation to 1 (0=portrait, 1=landscape, 2=auto, 3=sensorPortrait, 4=sensorLandscape)
    VPlayApplication: …adding this import path for VPlay engine: “:/qml”
    VPlayApplication: adding pluginPathGeneric as importPath: “plugins/generic”
    VPlayApplication: adding PLATFORM_PLUGIN_PATH as importPath: “plugins/windows”
    VPlayApplication: importPathList: (“C:/Projects/_VPlay/untitledTest2-build-desktop-Qt_4_8_1_for_Desktop_-_MSVC2010__Qt_SDK__Debug/qml”, “C:/Projects/_VPlay/untitledTest2-build-desktop-Qt_4_8_1_for_Desktop_-_MSVC2010__Qt_SDK__Debug/plugins/windows”, “C:/Projects/_VPlay/untitledTest2-build-desktop-Qt_4_8_1_for_Desktop_-_MSVC2010__Qt_SDK__Debug/plugins/generic”, “:/qml”, “C:/Projects/_VPlay/untitledTest2-build-desktop-Qt_4_8_1_for_Desktop_-_MSVC2010__Qt_SDK__Debug/debug”, “C:/VPlaySDK/Desktop/Qt/4.8.1/msvc2010/imports”)
    VPlayApplication: pluginPathList: (“.”)
    VPlayApplication:startApplication()
    VPlayApplication: rootContext of qmlViewer:  QDeclarativeContext(0xed5de0)
    VPlayApplication: using CocosDenshion for audio
    …before cocosApplication.run()
    cocos2d: cocos2d-1.0.1-x-0.12.0
    PVRVFrameSetGlesLibraryPath: C:\VPlaySDK\Desktop\V-PlaySDK\lib\third_party\libGLES_CM.dll
    PVRVFrameSetGlesv2LibraryPath: C:\VPlaySDK\Desktop\V-PlaySDK\lib\third_party\libGLESv2.dll
    C:\Projects\_VPlay\untitledTest2-build-desktop-Qt_4_8_1_for_Desktop_-_MSVC2010__Qt_SDK__Debug\debug\untitledTest2.exe exited with code 0

     

    #5321

    Raimonds

    Is there any solution how to enable project run when i connected with Remote Desktop Connection?

    #5331

    Alex
    V-Play Team

    Does the error also appear when running a Qt-Quick application instead of a V-Play project?

    #5333

    Raimonds

    No, simple QtQuick application runs well. Error is only on vplay based projects…

    #5335

    Alex
    V-Play Team

    HI again,

    what client are you using for RDC? One of our developers is using TeamViewer without having any problems. Would this be an option for you too?

    Cheers,
    Alex

    #5336

    Raimonds

    I’m using default Windows Remote Desktop connection – mstsc.exe

    —–Windows 7 Home Premium SP1——-

    Remote Desktop Connection

    Shell Version: 6.1.7601

    Control version 6.1.7601

    Remote Desktop Protocol 7.1

    ————————

     

    I’m connecting from my Windows7 to Windows 8 Pro with Media Center

     

    No this option is not good because TeamViewer is much slower & i don’t want to leave opened session for security reasons…

    It would be “Nice to have” if this bug was fixed.

     

    #6499

    fabian.b

    Hi,

    are there any solutions for this problem yet?

    I´m facing exactly the same problem.

     

    Regards,

    Fabian

    #6504

    Alex
    V-Play Team

    Hi,

    quick recap:
    PC1 has V-Play installed and everything runs fine.
    PC2 is connecting to PC1 via RDC and is having the above error.

    Can you first of all try to install V-Play on PC2 and try if it works there without any problems?

    This is most likely a problem with your graphics card driver. Your system might switch graphic card profiles (or even the graphic card itself if you have multiple, like one onboard and one pci) when using RDC. We have experienced a very similar issue once.

    Cheers,
    Alex

    #6520

    Raimonds

    Hi,

    When i had this error… both(PC1 and PC2) had installed working v-play and one graphic card.

     

    Raimonds

    #6523

    fabian.b

    Hi,

    Ok, here is the whole story. I have the problem on WIndows 7 Ultimate running in a virtual machine on Mac OSX 10.9 so both systems share the same graphic card. On Mac v-play works “fine” but low resolution images are not displayed correctly on my retina display due to i guess missing retina support of v-play. So i wanted to try running v-play on a virtualized windows because there i can scale the screen resolution down to something v-play supports.

    And so in windows there is the error, which is described above. I am currently working with a external monitor to avoid the retina problems. So on Mac OSX it’s working fine, but it would be nice to get it running on Windows too.

     

    Regards,

    fabian

    #6544

    Christian
    V-Play Team

    Hi fabian,

    Regarding the Mac retina issue: did you also try to build your games with daily build 1.5.4? We have fixed all known issues for Mac retina screens in that version – if you do have problems still please let us know.

    Cheers, Chris

    #6894

    Yong-Long

    Hi,

    My solution of this error is by update  graphic card driver to new one.

    for example, my pc  install  GeForce 7300 LE card, the update driver is  307.83.

    Please try update your PC’s graphic card or Display card driver to new one.

     

    • This reply was modified 4 years, 8 months ago by  ylliu.
Viewing 14 posts - 1 through 14 (of 14 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support