Forums

OverviewV-Play Installation › Install latest Qt Creator problems

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #5694

    Stefan

    Hi,

    I’ve installed the newest version of the Qt Creator like here: http://v-play.net/doc/vplay-installation.html
    But I don’t know how to configure it to work with V-Play.

    I tried to specify the compiler like in the old version but it says “No compiler can build code for this Qt-Version”.

    And I need to configure a “kit” in the new Qt-Creator…

    An installer which comes with the new Qt-Creator would be great,

    or a tutorial how to configure it!

    #5695

    Christian
    V-Play Team

    Hi lqscope,

    you are right, a tutorial abou this would be good!

    Meanwhile, you can do the following steps (for Windows, Mac & Linux are similar):

    1. Add a Qt version manually and point it to <V-PlaySDK>\Desktop\Qt\4.8.1\mingw\bin\qmake.exe
    2. Add the MinGW compiler manually by choosing the following compiler path: <V-PlaySDK>\mingw\bin\mingw32-g++.exe
    3. You now can add a manual Kit and name it e.g. “Qt 4.8.1 MinGW”, and select the manually added Qt version from step 1 and the compiler of step2

    Please let me know if you have any further problems.

    Cheers, Chris

    #5711

    Stefan

    Hi,

    thank you very much.

    You could add this to the documentation :)

    #5712

    Christian
    V-Play Team

    You are right, we’ll add it to the next daily build version of the docs!

    Cheers, Chris

    #5818

    Elisabeth

    Hi,

     

    there is another problem when upgrading qtcreator on linux 64bit: the symlink ./Desktop/Qt/4.8.1/gcc/mkspecs/default points to “linux-g++-64” while in ./Qt/4.8.1/gcc/mkspecs/features/v-play.prf “linux-g++” is tested –> directories are not set correctly.

     

    Possible solutions are to symlink to linux-g++ in the mkspecs directory or to manually override by adding -spec linux-g++ to the kit. It would be nice if you could adapt the *.prfs…

     

    Cheers,

    Thomas

    #5821

    Christian
    V-Play Team

    Thanks Thomas!

    I currently dont have a 64bit linux machine available – could you confirm if you change the

    • line 7 from”linux-g++” to “linux-g++|linux-g++-64”
    • line 17 from “macx|win32|linux-g++” to “macx|win32|linux-g++|linux-g++-64”
    • and in line 149 from “linux-g++” to “linux-g++|linux-g++-64”

    If that works, I will change the prf files so they are available with the next update.

    Cheers, Chris

    #5836

    Elisabeth

    Hi Chris,

     

    surprisingly it doesn’t work! Now I get these linker errors:

    /usr/bin/ld: skipping incompatible /home/thomske/V-PlaySDK/Desktop/Qt/4.8.1/gcc/../../../V-PlaySDK/lib/third_party/libcurl.a when searching for -lcurl
    /usr/bin/ld: cannot find -lcurl
    /usr/bin/ld: skipping incompatible /home/thomske/V-PlaySDK/Desktop/Qt/4.8.1/gcc/../../../V-PlaySDK/lib/third_party/libfreetype.a when searching for -lfreetype
    /usr/bin/ld: skipping incompatible /home/thomske/V-PlaySDK/Desktop/Qt/4.8.1/gcc/../../../V-PlaySDK/lib/third_party/libjpeg.a when searching for -ljpeg
    /usr/bin/ld: skipping incompatible /home/thomske/V-PlaySDK/Desktop/Qt/4.8.1/gcc/../../../V-PlaySDK/lib/third_party/libxml2.a when searching for -lxml2
    /usr/bin/ld: cannot find -lxml2
    /usr/bin/ld: skipping incompatible /home/thomske/V-PlaySDK/Desktop/Qt/4.8.1/gcc/../../../V-PlaySDK/lib/third_party/libfmodex.so when searching for -lfmodex
    /usr/bin/ld: cannot find -lfmodex
    collect2: ld returned 1 exit status

    Bye,

    Thomas

     

    SOLVED: It works after lines 53, 153 and 169 are also treated like above…

    #5839

    Christian
    V-Play Team

    Great, thanks for letting us know Thomas! The new prf will be available with the next daily build.

    Cheers, Chris

    #6418

    Vlad

    Hi

    trying to use QtCreator 3.0. on ubuntu 13.10  Added 4.8.1 qmake but when run qmake on the project got:

    14:05:00: Running steps for project vplaytest…

    14:05:00: Starting: “/home/vladest/V-PlaySDK/Desktop/Qt/4.8.1/gcc/bin/qmake” /home/vladest/development/vplaytest/vplaytest.pro -r -spec linux-g++-64

    Project MESSAGE: V-Play SDK path:

    Project MESSAGE: V-Play target path:

    Project MESSAGE: V-Play library path: /lib

    Project MESSAGE: V-Play qml path: /qml

    Project MESSAGE: V-Play include path: /include

    Project MESSAGE: VPlayPluginsGenericPath: /plugins/generic

    Project MESSAGE: VPlayPluginsPlatformPath: /

    Project MESSAGE: QML_IMPORT_PATH: /qml / /plugins/generic

    WARNING: /home/vladest/V-PlaySDK/Desktop/Qt/4.8.1/gcc/mkspecs/features/v-play.prf:250: Unable to find file for inclusion /qmlapplicationviewer/vplayqmlapplicationviewer.pri

    /home/vladest/V-PlaySDK/Desktop/Qt/4.8.1/gcc/mkspecs/features/v-play.prf:251: Unknown test function: qtcAddDeployment

    14:05:00: The process “/home/vladest/V-PlaySDK/Desktop/Qt/4.8.1/gcc/bin/qmake” exited normally.

     

    ie none of the path-es are set correctly

    how to fix this?

    Also, how to switch to daily updates?

     

    Thanks,

    Vlad

    #6426

    Christian
    V-Play Team
Viewing 10 posts - 1 through 10 (of 10 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support