Forums

OverviewV-Play 1 Support › Flurry

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #4313

    Christian
    V-Play Team

    Hi,

    I just tried adding the flurry component to our game.

    In QtCreator, i get the line
    import VPlay.plugins.flurry 1.0
    to be underlined red. Error message: QML module not found.

    The game can still be started on the desktop.

    But when I let the app be built on the build server (test mode), and installed it on my Android device, it crashed directly after startup.

    LogCat for Android revealed the following output:

    module "VPlay.plugins.flurry" is not installed
    -> import VPlay.plugins.flurry 1.0

    WARNING: VPlayApplication: no GameWindow item found, so could not set the rootGameWindow contextProperty as well!

    WARNING: VPlayApplication: the root object was not found, thus the size of it can not be set to the display size retrieved from cocos!
    Did I forget something?

    Looking forward to cool flurry analytics :)

     

    Cheers, Chrisu

     

    EDIT/PS: How are you supposed to get the user ID / user age / user gender in your app? Do you need to ask the user?

    #4314

    Alex
    V-Play Team

    Hi Chrisu,

    regarding Plugins on Build Server we currently only mention the usage in the deployment guide: http://v-play.net/doc/vplay-deployment.html#config-json. In order to link against a specific plugin you have to tell the Build Server which one with the help of the config.json file in your game’s qml root folder with an additional line:

    "plugins": [ "flurry" ]

    You can also have a look at Squaby’s config.json file for reference. The documentation of the upcoming update will point that out in more detail.

    Thanks for pointing out the error in Qt Creator, we will check that, I guess you’re currently using SDK version 1.2?

    And finally, yes, you would have to prompt the user and then set user age and other demographics by your own if you want accurate data about your audience, otherwise Flurry tries to fill the data automatically with “Flurry Estimates”.

    Cheers,
    Alex

    #4319

    Christian
    V-Play Team

    Hey Alex,

     

    thanks for your answer!

    It’s working now, and the update of Blockoban with flurry and some other new features will soon be available 😉

    And yes, I’m using SDK 1.2, but I have never tried the flurry plugin with older versions.

    #4323

    Alex
    V-Play Team

    Chrisu said:

    It’s working now, and the update of Blockoban with flurry and some other new features will soon be available 😉

    Glad to here, we are looking forward to the update! :)

Viewing 4 posts - 1 through 4 (of 4 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support