Forums

OverviewV-Play 2 Support (Qt 5) › compile ios error after update v-play to 2.6

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #10676

    Bas

    i build on commandline and get this error on IOS:

    do i mis some linker settings?

    Undefined symbols for architecture arm64:

      “QWebSocket::errorString() const”, referenced from:

          QQmlWebSocket::onError(QAbstractSocket::SocketError) in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::open(QUrl const&)”, referenced from:

          QQmlWebSocket::setUrl(QUrl const&) in libVPlay.a(vplaywebsocket.o)

          QQmlWebSocket::componentComplete() in libVPlay.a(vplaywebsocket.o)

          QQmlWebSocket::setActive(bool) in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::QWebSocket(QString const&, QWebSocketProtocol::Version, QObject*)”, referenced from:

          QQmlWebSocket::componentComplete() in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::textMessageReceived(QString const&)”, referenced from:

          QQmlWebSocket::setSocket(QWebSocket*) in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::staticMetaObject”, referenced from:

          QQmlWebSocket::setSocket(QWebSocket*) in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::closeReason() const”, referenced from:

          QQmlWebSocket::closeReason() in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::sendTextMessage(QString const&)”, referenced from:

          QQmlWebSocket::sendTextMessage(QString const&) in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::closeCode() const”, referenced from:

          QQmlWebSocket::closeCode() in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::close(QWebSocketProtocol::CloseCode, QString const&)”, referenced from:

          QQmlWebSocket::setUrl(QUrl const&) in libVPlay.a(vplaywebsocket.o)

          QQmlWebSocket::close() in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::error(QAbstractSocket::SocketError)”, referenced from:

          QQmlWebSocket::setSocket(QWebSocket*) in libVPlay.a(vplaywebsocket.o)

      “QWebSocket::stateChanged(QAbstractSocket::SocketState)”, referenced from:

          QQmlWebSocket::setSocket(QWebSocket*) in libVPlay.a(vplaywebsocket.o)

    ld: symbol(s) not found for architecture arm64

    #10677

    Bas

    additional warnings, i don’t know where i can change these settings?

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(nativeutils_ios.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(videoviewitem_ios.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(platformutils_ios.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2PolygonShape.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2EdgeShape.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2CircleShape.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2ChainShape.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2TimeOfImpact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2DynamicTree.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Distance.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Collision.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2CollidePolygon.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2CollideEdge.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2CollideCircle.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2BroadPhase.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Timer.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2StackAllocator.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Settings.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Math.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Draw.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2BlockAllocator.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2PolygonContact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2PolygonAndCircleContact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2EdgeAndPolygonContact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2EdgeAndCircleContact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2ContactSolver.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Contact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2CircleContact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2ChainAndPolygonContact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2ChainAndCircleContact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2WheelJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2WeldJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2RopeJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2RevoluteJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2PulleyJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2PrismaticJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2MouseJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Joint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2GearJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2FrictionJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2DistanceJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2WorldCallbacks.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2World.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Island.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Fixture.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2ContactManager.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Body.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2Rope.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(b2MotorJoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dplugin.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dworld.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dcontact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dbody.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dfixture.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2ddebugdraw.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2djoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2ddistancejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dprismaticjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2drevolutejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dmotorjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dweldjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dpulleyjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dfrictionjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dwheeljoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dmousejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dgearjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2dropejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(box2draycast.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(system.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(steertopointbehavior.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(AIOperations.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(movementanimation.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(particleitem.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(videoviewitem.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(vplayscheduler.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(vplaytask.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(typewriteritem.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(itemeditor.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(vplayfileutils.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(nativeutils.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(vplayurlinterceptor.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(aes.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(licensevalidator.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(vplaywebsocket.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(json.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(vpapplication.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(globalkeyforwarder.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(CircularStateMachine.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(TexturePackerSprite.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(TexturePackerSpriteCommons.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(qrc_resources_vplay.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(qrc_resources_vplay_plugins.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(qrc_resources_vplayapps.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dplugin.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dworld.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dcontact.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dbody.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dfixture.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2ddebugdraw.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2djoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2ddistancejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dprismaticjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2drevolutejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dmotorjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dweldjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dpulleyjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dfrictionjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dwheeljoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dmousejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dgearjoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2dropejoint.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_box2draycast.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_system.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_nativeutils.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_steertopointbehavior.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_vpapplication.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_movementanimation.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_particleitem.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_videoviewitem.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_vplayscheduler.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_vplaytask.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_typewriteritem.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_itemeditor.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_vplayfileutils.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_globalkeyforwarder.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_licensevalidator.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_vplaywebsocket.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_CircularStateMachine.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    ld: warning: object file (/Users/bas/V-PlaySDK/5.5/ios/lib/libVPlay.a(moc_TexturePackerSprite.o)) was built for newer iOS version (5.1.1) than being linked (5.1)

    #10678

    Bas

    ok i made some progress, i wanted to build an .xcarchive

    with command line parameters :

    xcodebuild -scheme [name] clean archive -archivePath build/[name]

    and  i want to extract the ipa with (assuming that path “build” exists in release build folder):

    xcodebuild -exportArchive -exportFormat ipa -archivePath “build/[name].xcarchive” -exportPath “build/[name].ipa” -exportProvisioningProfile “iOSTeam Provisioning Profile: [provisioning profilename]”

    So i fisrt needed to opened the xcode project and change the deployement_target to 6.0

    and built a release version from within QT, before i could do the command line stuff.

    • This reply was modified 3 years, 1 month ago by  zzzax.
    #10732

    Alex
    V-Play Team

    Hi,

    That’s a bunch of issues, let’s try to get that sorted:

    – First of all, the iOS version linker warnings can be ignored and will be fixed with the upcoming Qt update

    – How are you triggering your command line builds? qmake, and xcrun/xcodebuild? You have to make sure that the qmake target and the Xcode target match the architectures for that.

    – You can set your iOS deployment target from within your Qt project file with “QMAKE_IOS_DEPLOYMENT_TARGET = 6.0”, in that way the Xcode project is already created with the correct target and you don’t have to open the project manually.

    Best,

    Alex

    #10733

    Bas

    i use a utility called airsign for re-code signing and testing.

    so i needed the ipa, but did’n know how to get it :)

    therefore i used the command line parameters to extract the ipa from the .xcarchive

    i got an error for build-target mismatch, i opened the xcode project and set the target there, then i used commandline again :)

     

    #10741

    Alex
    V-Play Team

    Ah I see, yes, IPA creation got a lot harder since Xcode 6. Regarding the build target, did you also try to add the “-sdk iphoneos” parameter to the xcodebuild call?

    Cheers,

    Alex

    #10742

    Bas

    hi Alex,

    no i did not used that parameter, it works for now :)
    but thanx for the suggestions!

Viewing 7 posts - 1 through 7 (of 7 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support