Forums

OverviewV-Play 1 Support › App instantly closes saying the application has been stopped

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #7417

    Lasse

    When I run my flappy bird app, the screen rotates and then a popup message occurs saying the application has stopped. It works fine on windows with no problems at all. I also tried checking the logs but there were none.

    • This topic was modified 4 years, 7 months ago.
    • This topic was modified 4 years, 7 months ago.
    #7420

    Alex
    V-Play Team

    Hi,

    did you change/add images? Mobile devices are case sensitive, so check if you use the right paths. What platform are you trying to run it on?

    Cheers,
    Alex

    #7421

    Lasse

    alex.huber said:

    Hi,

    did you change/add images? Mobile devices are case sensitive, so check if you use the right paths. What platform are you trying to run it on?

    Cheers,
    Alex

    I changed the texture pack but I didn’t change any of the names. I am trying to run it on Android KitKat

    #7422

    Alex
    V-Play Team

    Did you check the logcat output of your device or did you only check the log on desktop?

    #7423

    Lasse

    alex.huber said:

    Did you check the logcat output of your device or did you only check the log on desktop?

    I checked the logcat output of my device. VPlayGameNetworkScene is showing up as unknown in main.qml, could I be missing something?

    • This reply was modified 4 years, 7 months ago by  KaNN.
    • This reply was modified 4 years, 7 months ago by  KaNN.
    #7426

    Alex
    V-Play Team

    You could indeed be missing the VPlayGameNetworkScene 😉

    In our FlappyBird Demo game it is located in the scenes folder, please check if it is there.

    Also you mentioned the screen is rotating before shutdown? Check your config.json, you need to set the orientation to portrait.

    Cheers,
    Alex

    • This reply was modified 4 years, 7 months ago by  Alex.
    #7428

    Lasse

    alex.huber said:

    You could indeed be missing the VPlayGameNetworkScene 😉

    In our FlappyBird Demo game it is located in the scenes folder, please check if it is there.

    Also you mentioned the screen is rotating before shutdown? Check your config.json, you need to set the orientation to portrait.

    Cheers,
    Alex

    Hm, weird, for some reason I am still getting the crashes, you were right about the network scene though :)

    #7429

    Lasse

    I managed to pull some logs.

     

    04-14 16:11:31.527 W/Qt      (6069): file::/qml/Main.qml:83:3: Type VPlayGameNetworkScene unavailable

    04-14 16:11:31.527 W/Qt      (6069):        VPlayGameNetworkScene {

    04-14 16:11:31.527 W/Qt      (6069):        ^

    04-14 16:11:31.527 W/Qt      (6069): file::/qml/scenes/VPlayGameNetworkScene.qml:12:3: VPlayGameNetworkView is not a type

    04-14 16:11:31.527 W/Qt      (6069):        VPlayGameNetworkView {

    04-14 16:11:31.527 W/Qt      (6069):        ^

    04-14 16:11:31.527 W/Qt      (6069): WARNING: VPlayApplication: no GameWindow item found, so could not set the rootGameWindow contextProperty as well!

    04-14 16:11:31.527 W/Qt      (6069): WARNING: VPlayApplication: the root object was not found, thus the size of it can not be set to the display size retrieved from cocos!

    04-14 16:11:31.537 F/libc    (6069): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)

     

    EDIT: deleted unimportant parts of the log

    • This reply was modified 4 years, 7 months ago by  Alex.
    #7430

    Alex
    V-Play Team

    Did you use “sdk”: “daily” in your config.json?

    From the documentation: “Note: The VPlayGameNetwork component is only available since V-Play Daily Build v1.5.4. So to use the daily build version on the Build Server add the "sdk": "daily" part to your config file.”

    Cheers,
    Alex

    #7432

    Lasse

    alex.huber said:

    Did you use “sdk”: “daily” in your config.json?

    From the documentation: “<b>Note:</b> The VPlayGameNetwork component is only available since V-Play Daily Build v1.5.4. So to use the daily build version on the Build Server add the <tt>”sdk”: “daily”</tt> part to your config file.”

    Cheers,
    Alex

    I hadn’t done that but the game still just stops :/

    #7433

    Lasse

    Can’t edit my last post, but it is 100% something to do with VPlayGameNetwork, since I tried disabling it and then the app ran, but I just wonder what the hell I messed up.

    #7434

    Alex
    V-Play Team

    How did you disable it?

    #7435

    Lasse

    alex.huber said:

    How did you disable it?

    I removed the alias and the VPlayGameNetworkScene in main.qml

    #7436

    Alex
    V-Play Team

    Did you also delete all the other references of the item (“gameNetwork” and “vplayGameNetworkScene”)? E.g. in the states. You can search in the whole project with ctrl+shift+f.

    Cheers,
    Alex

    • This reply was modified 4 years, 7 months ago by  Alex.
    #7438

    Lasse

    alex.huber said:

    Did you also delete all the other references of the item? E.g. in the states. You can search in the whole project with ctrl+shift+f.

    Cheers,
    Alex

    No I didn’t delete any other references, but I kinda wanna keep VPlayGameNetwork as it is the thing that keeps track of your highscore.

Viewing 15 posts - 1 through 15 (of 20 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support