Forums

OverviewV-Play 2 Support (Qt 5) › Android Deployment

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #8284

    Nour
    #8285

    Christian
    V-Play Team

    Hi,

    from the docs about Publish Builds:

    To enable a Publish Build, set "stage": "publish" in your config.json file in the qml folder and build a Release Build from Qt Creator.

    Cheers, Chris

    #8286

    Nour

    Hi Chris

    I did this before..

    there warning when i run app on device “missing config.json”

    i dont know if this related

     

    this is my file

    {
    “title”: “Dominoes”,
    “identifier”: “com.maysalward.Dominoes”,
    “orientation”: “landscape”,
    “versioncode”: 2000004,
    “versionname”: “3.3”,
    “stage”: “publish”
    }

     

    #8287

    Christian
    V-Play Team

    Hi,

    can you try to create a new Empty V-Play Project from the wizard, and then set the stage to publish in the config.json file. The devBuild text should then be invisible.

    Cheers, Chris

    #8288

    Nour

    Hi

    I am stuck now with V-Play icon in addition to that text

    may i can send a sample of the code

     

    Thanks

    #8771

    Nour

    Hi

     

    The problem raise again, i tried to edit .pro file and  have it like this

     

    #allowstoaddDEPLOYMENTFOLDERSandlinkstotheV-PlaylibraryandQtCreatorauto-completion

    TEMPLATE=app
    CONFIG+=v-play
    QT+=qmlquick
    
    
    qmlFolder.source=qml
    #DEPLOYMENTFOLDERS+=qmlFolder#commentforpublishing
    
    
    assetsFolder.source=assets
    DEPLOYMENTFOLDERS+=assetsFolder
    
    
    #Addmorefolderstoshipwiththeapplicationhere
    
    
    RESOURCES+=\
    resources.qrc#uncommentforpublishing
    and edited main.cpp but the text is still shown
    please help
    
    
    thanks
    #8772

    Christian
    V-Play Team

    Hi,

    I just tried it as well, and it worked fine – the text is not displayed when setting the stage to publish (both when I enabled resources, and also with the default deploymentfolders settings).

    Can you try if the text is shown when you create a new Empty V-Play Project? (both when enabling deploymentfolders, and also resources)

    Cheers, Chris

    #8779

    Nour

    I am not able to go with publish build on new project

    This error shown on console

    W/Qt (18299): (null):0 ((null)): [System]- [WARNING]: System can’t parse stringData file “{

    W/Qt (18299): “title”: “Untitled1”,

    W/Qt (18299): “identifier”: “com.maysalward.tarneeb”,

    W/Qt (18299): “orientation”: “landscape”,

    W/Qt (18299): “versioncode”: 5,

    W/Qt (18299): “sdk”: “daily”,

    W/Qt (18299): “versionname”: “3.0”,

    W/Qt (18299): “stage”: “publish”

    W/Qt (18299): }”

    #8782

    Christian
    V-Play Team
Viewing 9 posts - 1 through 9 (of 9 total)

RSS feed for this thread

You must be logged in to reply to this topic.

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support