Forums

OverviewV-Play InstallationInstallation problem : error: cannot find -lGL › Reply To: Installation problem : error: cannot find -lGL

OverviewV-Play InstallationInstallation problem : error: cannot find -lGL › Reply To: Installation problem : error: cannot find -lGL
#10215

Ryan

I created an empty v-play app an tried to run it. These are the errors i get in the different tabs.

App code:

App {
    // You get free licenseKeys from http://v-play.net/licenseKey
    // With a licenseKey you can:
    //  * Publish your games & apps for the app stores
    //  * Remove the V-Play Splash Screen or set a custom one (available with the Pro Licenses)
    //  * Add plugins to monetize, analyze & improve your apps (available with the Pro Licenses)
    //licenseKey: "<generate one from http://v-play.net/licenseKey>"

    NavigationStack {

        Page {
            title: qsTr("Main Page")

            Image {
                source: "../assets/vplay-logo.png"
                anchors.centerIn: parent
            }
        }

    }
}

 

General messages:

Project MESSAGE: Link with V-Play library: VPlay_debug

Project MESSAGE: MAINPROFILEPWD: /home/theguy/EmptyApp

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/android_armv5/qml/QtWebSockets:

/home/theguy/V-Play/5.5/android_armv5/qml/QtWebSockets/plugins.qmltypes:1:24: Reading only version 1.1 parts.

/home/theguy/V-Play/5.5/android_armv5/qml/QtWebSockets/plugins.qmltypes:10:5: Expected only Component and ModuleApi object definitions.

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/android_armv5/qml/QtCanvas3D:

/home/theguy/V-Play/5.5/android_armv5/qml/QtCanvas3D/plugins.qmltypes:1:24: Reading only version 1.1 parts.

/home/theguy/V-Play/5.5/android_armv5/qml/QtCanvas3D/plugins.qmltypes:10:5: Expected only Component and ModuleApi object definitions.

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/android_armv7/qml/QtWebSockets:

/home/theguy/V-Play/5.5/android_armv7/qml/QtWebSockets/plugins.qmltypes:1:24: Reading only version 1.1 parts.

/home/theguy/V-Play/5.5/android_armv7/qml/QtWebSockets/plugins.qmltypes:10:5: Expected only Component and ModuleApi object definitions.

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/android_armv7/qml/QtCanvas3D:

/home/theguy/V-Play/5.5/android_armv7/qml/QtCanvas3D/plugins.qmltypes:1:24: Reading only version 1.1 parts.

/home/theguy/V-Play/5.5/android_armv7/qml/QtCanvas3D/plugins.qmltypes:10:5: Expected only Component and ModuleApi object definitions.

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/gcc_64/qml/QtWebSockets:

/home/theguy/V-Play/5.5/gcc_64/qml/QtWebSockets/plugins.qmltypes:1:24: Reading only version 1.1 parts.

/home/theguy/V-Play/5.5/gcc_64/qml/QtWebSockets/plugins.qmltypes:10:5: Expected only Component and ModuleApi object definitions.

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/gcc_64/qml/QtCanvas3D:

/home/theguy/V-Play/5.5/gcc_64/qml/QtCanvas3D/plugins.qmltypes:1:24: Reading only version 1.1 parts.

/home/theguy/V-Play/5.5/gcc_64/qml/QtCanvas3D/plugins.qmltypes:10:5: Expected only Component and ModuleApi object definitions.

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/gcc_64/qml/Qt3D:

<dump of /home/theguy/V-Play/5.5/gcc_64/qml/Qt3D>:1:24: Reading only version 1.1 parts.

<dump of /home/theguy/V-Play/5.5/gcc_64/qml/Qt3D>:10:5: Expected only Component and ModuleApi object definitions.

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/gcc_64/qml/Qt3D/Renderer:

<dump of /home/theguy/V-Play/5.5/gcc_64/qml/Qt3D/Renderer>:1:24: Reading only version 1.1 parts.

<dump of /home/theguy/V-Play/5.5/gcc_64/qml/Qt3D/Renderer>:10:5: Expected only Component and ModuleApi object definitions.

QML module does not contain information about components contained in plugins.

Module path: /home/theguy/V-Play/5.5/android_armv7/qml/QtQuick/Controls/Styles/Android

See “Using QML Modules with Plugins” in the documentation.

Automatic type dump of QML module failed.

Errors:

“/home/theguy/V-Play/5.5/gcc_64/bin/qmlplugindump” returned exit code 3.

Arguments: -nonrelocatable QtQuick.Controls.Styles.Android 1.0 /home/theguy/V-Play/5.5/android_armv7/qml

QQmlComponent: Component is not ready

QML module does not contain information about components contained in plugins.

Module path: /home/theguy/V-Play/5.5/android_armv7/qml/Qt3D/Renderer

See “Using QML Modules with Plugins” in the documentation.

Automatic type dump of QML module failed.

Errors:

“/home/theguy/V-Play/5.5/gcc_64/bin/qmlplugindump” returned exit code 3.

Arguments: -nonrelocatable Qt3D.Renderer 2.0 /home/theguy/V-Play/5.5/android_armv7/qml

QQmlComponent: Component is not ready

Warnings while parsing QML type information of /home/theguy/V-Play/5.5/gcc_64/qml/QtQuick/Scene3D:

<dump of /home/theguy/V-Play/5.5/gcc_64/qml/QtQuick/Scene3D>:1:24: Reading only version 1.1 parts.

<dump of /home/theguy/V-Play/5.5/gcc_64/qml/QtQuick/Scene3D>:10:5: Expected only Component and ModuleApi object definitions.

QML module does not contain information about components contained in plugins.

Module path: /home/theguy/V-Play/5.5/android_armv7/qml/Qt3D

See “Using QML Modules with Plugins” in the documentation.

Automatic type dump of QML module failed.

Errors:

“/home/theguy/V-Play/5.5/gcc_64/bin/qmlplugindump” returned exit code 3.

Arguments: -nonrelocatable Qt3D 2.0 /home/theguy/V-Play/5.5/android_armv7/qml

QQmlComponent: Component is not ready

QML module does not contain information about components contained in plugins.

Module path: /home/theguy/V-Play/5.5/android_armv7/qml/QtQuick/Scene3D

See “Using QML Modules with Plugins” in the documentation.

Automatic type dump of QML module failed.

Errors:

“/home/theguy/V-Play/5.5/gcc_64/bin/qmlplugindump” returned exit code 3.

Arguments: -nonrelocatable QtQuick.Scene3D 2.0 /home/theguy/V-Play/5.5/android_armv7/qml

QQmlComponent: Component is not ready

 

Compile output:

qrc_resources_user.o -L/home/theguy/V-Play/5.5/gcc_64/lib -lVPlay -lQt5Quick -L/usr/lib64 -lQt5Widgets -lQt5Multimedia -lQt53DInput -lQt53DRenderer -lQt53DQuick -lQt53DCore -lQt5OpenGLExtensions -lQt5Gui -lQt5Qml -lQt5Network -lQt5Sql -lQt5Core -lGL -lpthread

/usr/bin/ld: cannot find -lGL

Makefile:212: recipe for target ‘EmptyApp’ failed

collect2: error: ld returned 1 exit status

make: *** [EmptyApp] Error 1

17:46:12: The process “/usr/bin/make” exited with code 2.

Error while building/deploying project EmptyApp (kit: Desktop Qt 5.5.0 GCC 64bit)

When executing step “Make”

 

Issues tab:

:-1: error: cannot find -lGL

:-1: error: collect2: error: ld returned 1 exit status

Voted #1 for:

  • Easiest to learn
  • Most time saving
  • Best support

Develop Cross-Platform Apps and Games 50% Faster!

  • Voted the best supported, most time-saving and easiest to learn cross-platform development tool
  • Based on the Qt framework, with native performance and appearance on all platforms including iOS and Android
  • Offers a variety of plugins to monetize, analyze and engage users
FREE!
create apps
create games
cross platform
native performance
3rd party services
game network
multiplayer
level editor
easiest to learn
biggest time saving
best support